use strict;
my $str = '%ABC%
$ABC.
$ABC$XYZ
To add a bit more to this:
${ABC}
should yield ABC too. (ignore curly braces if present - non capture chars perhaps?).
if you have two successive dollar signs, such as "$$EFG", or "$${EFG}",
that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:).';
my $regex = qr/%([^%.]+)%|(?<!\$)\$(?:\{([^{}]+)\}|([^$.\s]+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}