$re = '/%([^%.]+)%|(?<!\$)\$(?:\{([^{}]+)\}|([^$.\s]+))/m';
$str = '%ABC%
$ABC.
$ABC$XYZ
To add a bit more to this:
${ABC}
should yield ABC too. (ignore curly braces if present - non capture chars perhaps?).
if you have two successive dollar signs, such as "$$EFG", or "$${EFG}",
that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);