#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:real\s*?subs(?:tance)??|subs(?:tance)??\s*?real)$"
Local $sString = "real substance" & @CRLF & _
"" & @CRLF & _
"substance real" & @CRLF & _
"" & @CRLF & _
"real substance group" & @CRLF & _
"" & @CRLF & _
"Real Substance External" & @CRLF & _
"" & @CRLF & _
"Real Substance" & @CRLF & _
"" & @CRLF & _
"Substance Real" & @CRLF & _
"" & @CRLF & _
"real subs" & @CRLF & _
"" & @CRLF & _
"subs real" & @CRLF & _
"" & @CRLF & _
"real subs group" & @CRLF & _
"" & @CRLF & _
"group real subs" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")