// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:real\s*?subs(?:tance)??|subs(?:tance)??\s*?real)$").unwrap();
let string = "real substance
substance real
real substance group
Real Substance External
Real Substance
Substance Real
real subs
subs real
real subs group
group real subs
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}