re = /^(?:real\s*?subs(?:tance)??|subs(?:tance)??\s*?real)$/m
str = 'real substance
substance real
real substance group
Real Substance External
Real Substance
Substance Real
real subs
subs real
real subs group
group real subs
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end