import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:real\\s*?subs(?:tance)??|subs(?:tance)??\\s*?real)$";
final String string = "real substance\n\n"
+ "substance real\n\n"
+ "real substance group\n\n"
+ "Real Substance External\n\n"
+ "Real Substance\n\n"
+ "Substance Real\n\n"
+ "real subs\n\n"
+ "subs real\n\n"
+ "real subs group\n\n"
+ "group real subs\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}