import re
regex = re.compile(r"^(?:real\s*?subs(?:tance)??|subs(?:tance)??\s*?real)$", flags=re.MULTILINE)
test_str = ("real substance\n\n"
"substance real\n\n"
"real substance group\n\n"
"Real Substance External\n\n"
"Real Substance\n\n"
"Substance Real\n\n"
"real subs\n\n"
"subs real\n\n"
"real subs group\n\n"
"group real subs\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")