package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:real\s*?subs(?:tance)??|subs(?:tance)??\s*?real)$`)
var str = `real substance
substance real
real substance group
Real Substance External
Real Substance
Substance Real
real subs
subs real
real subs group
group real subs
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}