$re = '/^(?:real\s*?subs(?:tance)??|subs(?:tance)??\s*?real)$/m';
$str = 'real substance
substance real
real substance group
Real Substance External
Real Substance
Substance Real
real subs
subs real
real subs group
group real subs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);