using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:real\s*?subs(?:tance)??|subs(?:tance)??\s*?real)$";
string input = @"real substance
substance real
real substance group
Real Substance External
Real Substance
Substance Real
real subs
subs real
real subs group
group real subs
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}