#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^UC-000(?:0\d|[1-9]\d*)$"
Local $sString = "UC-00001" & @CRLF & _
"UC-00012" & @CRLF & _
"UC-000100" & @CRLF & _
"" & @CRLF & _
"UC-00001" & @CRLF & _
"UC-00010" & @CRLF & _
"UC-00000" & @CRLF & _
"UC-000010" & @CRLF & _
"UC-0000100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")