$re = '/^UC-000(?:0\d|[1-9]\d*)$/m';
$str = 'UC-00001
UC-00012
UC-000100
UC-00001
UC-00010
UC-00000
UC-000010
UC-0000100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);