use strict;
my $str = 'UC-00001
UC-00012
UC-000100
UC-00001
UC-00010
UC-00000
UC-000010
UC-0000100';
my $regex = qr/^UC-000(?:0\d|[1-9]\d*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}