// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^UC-000(?:0\d|[1-9]\d*)$").unwrap();
let string = "UC-00001
UC-00012
UC-000100
UC-00001
UC-00010
UC-00000
UC-000010
UC-0000100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}