using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^UC-000(?:0\d|[1-9]\d*)$";
string input = @"UC-00001
UC-00012
UC-000100
UC-00001
UC-00010
UC-00000
UC-000010
UC-0000100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}