import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^UC-000(?:0\\d|[1-9]\\d*)$";
final String string = "UC-00001\n"
+ "UC-00012\n"
+ "UC-000100\n\n"
+ "UC-00001\n"
+ "UC-00010\n"
+ "UC-00000\n"
+ "UC-000010\n"
+ "UC-0000100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}