package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^UC-000(?:0\d|[1-9]\d*)$`)
var str = `UC-00001
UC-00012
UC-000100
UC-00001
UC-00010
UC-00000
UC-000010
UC-0000100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}