# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:--configuration|-c) ""(.*?)""/$/gi;t' <<< "debug --configuration \"Release\" \p corebuild
-c \"Dev\" debug
"