use strict;
my $str = 'debug --configuration "Release" \\p corebuild
-c "Dev" debug
';
my $regex = qr/(?:--configuration|-c) ""(.*?)""/ip;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";