re = /(?:--configuration|-c) ""(.*?)""/i
str = 'debug --configuration "Release" \\p corebuild
-c "Dev" debug
'
subst = '$'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result