using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:--configuration|-c) ""(.*?)""";
string substitution = @"$";
string input = @"debug --configuration ""Release"" \p corebuild
-c ""Dev"" debug
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}