import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:--configuration|-c) \"\"(.*?)\"\"";
final String string = "debug --configuration \"Release\" \\p corebuild\n"
+ "-c \"Dev\" debug\n\n";
final String subst = "$";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}