import re
regex = re.compile(r"(?:--configuration|-c) \"\"(.*?)\"\"", flags=re.IGNORECASE)
test_str = ("debug --configuration \"Release\" \\p corebuild\n"
"-c \"Dev\" debug\n\n")
subst = "$"
result = regex.sub(subst, test_str)
if result:
print(result)