$re = '/(?:--configuration|-c) ""(.*?)""/i';
$str = 'debug --configuration "Release" \\p corebuild
-c "Dev" debug
';
$subst = "$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;