// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(?:--configuration|-c) ""(.*?)"""#).unwrap();
let string = "debug --configuration \"Release\" \\p corebuild
-c \"Dev\" debug
";
let substitution = "$";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}