using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:[&,]|Featuring).*";
string substitution = @"";
string input = @"Drake
Post Malone Featuring Ty Dolla $ign
BlocBoy JB Featuring Drake
Offset & Metro Boomin
Jay Rock, Kendrick Lamar, Future & James Blake";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}