re = /\s*(?:[&,]|Featuring).*/
str = 'Drake
Post Malone Featuring Ty Dolla $ign
BlocBoy JB Featuring Drake
Offset & Metro Boomin
Jay Rock, Kendrick Lamar, Future & James Blake'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result