$re = '/\s*(?:[&,]|Featuring).*/';
$str = 'Drake
Post Malone Featuring Ty Dolla $ign
BlocBoy JB Featuring Drake
Offset & Metro Boomin
Jay Rock, Kendrick Lamar, Future & James Blake';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;