import re
regex = re.compile(r"\s*(?:[&,]|Featuring).*")
test_str = ("Drake\n"
"Post Malone Featuring Ty Dolla $ign\n"
"BlocBoy JB Featuring Drake\n"
"Offset & Metro Boomin\n"
"Jay Rock, Kendrick Lamar, Future & James Blake")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)