import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?:[&,]|Featuring).*";
final String string = "Drake\n"
+ "Post Malone Featuring Ty Dolla $ign\n"
+ "BlocBoy JB Featuring Drake\n"
+ "Offset & Metro Boomin\n"
+ "Jay Rock, Kendrick Lamar, Future & James Blake";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}