#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img\s(.*?)scr="((.*?)\/test234\/(.*?))"(.*?)>"
Local $sString = "Das ist ein Test <img scr="././test234/12345.jpg" border="0" alt="test"> bla blub blabub"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")