import re
regex = re.compile(r"<img\s(.*?)scr=\"((.*?)\/test234\/(.*?))\"(.*?)>")
test_str = "Das ist ein Test <img scr=\"././test234/12345.jpg\" border=\"0\" alt=\"test\"> bla blub blabub"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")