import Foundation
let pattern = #"<img\s(.*?)scr="((.*?)\/test234\/(.*?))"(.*?)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Das ist ein Test <img scr="././test234/12345.jpg" border="0" alt="test"> bla blub blabub"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}