using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\s(.*?)scr=""((.*?)\/test234\/(.*?))""(.*?)>";
string input = @"Das ist ein Test <img scr=""././test234/12345.jpg"" border=""0"" alt=""test""> bla blub blabub";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}