$re = '/<img\s(.*?)scr="((.*?)\/test234\/(.*?))"(.*?)>/';
$str = 'Das ist ein Test <img scr="././test234/12345.jpg" border="0" alt="test"> bla blub blabub';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);