import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\s(.*?)scr=\"((.*?)\\/test234\\/(.*?))\"(.*?)>";
final String string = "Das ist ein Test <img scr=\"././test234/12345.jpg\" border=\"0\" alt=\"test\"> bla blub blabub";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}