# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<((?!\\/?br\s?\\/?>)\s*)[^>]+>//gm;t' <<< "<!DOCTYPE html>
<head>
</head>
<body>
Ala ma kota
</body>
</html>
<br>ppp lll<br />
</br> pppp
<br/>
<body/>
<p>
<BR>
<brrr>
<br script=\"whatever\">"