import Foundation
let pattern = #"<((?!\/?br\s?\/?>)\s*)[^>]+>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<!DOCTYPE html>
<head>
</head>
<body>
Ala ma kota
</body>
</html>
<br>ppp lll<br />
</br> pppp
<br/>
<body/>
<p>
<BR>
<brrr>
<br script="whatever">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)