using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<((?!\/?br\s?\/?>)\s*)[^>]+>";
string substitution = @"";
string input = @"<!DOCTYPE html>
<head>
</head>
<body>
Ala ma kota
</body>
</html>
<br>ppp lll<br />
</br> pppp
<br/>
<body/>
<p>
<BR>
<brrr>
<br script=""whatever"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}