$re = '/<((?!\/?br\s?\/?>)\s*)[^>]+>/m';
$str = '<!DOCTYPE html>
<head>
</head>
<body>
Ala ma kota
</body>
</html>
<br>ppp lll<br />
</br> pppp
<br/>
<body/>
<p>
<BR>
<brrr>
<br script="whatever">';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;