use strict;
my $str = '<!DOCTYPE html>
<head>
</head>
<body>
Ala ma kota
</body>
</html>
<br>ppp lll<br />
</br> pppp
<br/>
<body/>
<p>
<BR>
<brrr>
<br script="whatever">';
my $regex = qr/<((?!\/?br\s?\/?>)\s*)[^>]+>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";