re = /<((?!\/?br\s?\/?>)\s*)[^>]+>/m
str = '<!DOCTYPE html>
<head>
</head>
<body>
Ala ma kota
</body>
</html>
<br>ppp lll<br />
</br> pppp
<br/>
<body/>
<p>
<BR>
<brrr>
<br script="whatever">'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result