import re
regex = re.compile(r"<((?!\/?br\s?\/?>)\s*)[^>]+>", flags=re.MULTILINE)
test_str = ("<!DOCTYPE html>\n"
"<head>\n"
"</head>\n"
"<body>\n"
"Ala ma kota\n"
"</body>\n"
"</html>\n"
"<br>ppp lll<br />\n"
"</br> pppp\n"
"<br/>\n"
"<body/>\n"
"<p>\n"
"<BR>\n"
"<brrr>\n"
"<br script=\"whatever\">")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)