use strict;
my $str = ' Thanks for the help! I\'ve been trying to meet with Jessica but she has cancelled so many times that I\'m discouraged
Bye Bye
email: peter@provider.com
Cell 1+800 888 888
';
my $regex = qr/^[ ]+|[ ]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";