import Foundation
let pattern = #"^[ ]+|[ ]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Thanks for the help! I've been trying to meet with Jessica but she has cancelled so many times that I'm discouraged
Bye Bye
email: peter@provider.com
Cell 1+800 888 888
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)