#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\blog\.(?:info|warn|error)\((?!\s*`DEBUG\b)[\w\W]*?\);"
Local $sString = "log.info(" & @CRLF & _
" `DEBUG other strings..." & @CRLF & _
");" & @CRLF & _
"log.info(" & @CRLF & _
" `remove this instruction!!!" & @CRLF & _
");" & @CRLF & _
"log.info(" & @CRLF & _
" `DEBUG other strings..." & @CRLF & _
");" & @CRLF & _
"log.info(`remove this instruction!!!);" & @CRLF & _
"log.info(`DEBUG other strings...);" & @CRLF & _
"" & @CRLF & _
"log.info(" & @CRLF & _
" `other strings DEBUG..." & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")