using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\blog\.(?:info|warn|error)\((?!\s*`DEBUG\b)[\w\W]*?\);";
string input = @"log.info(
`DEBUG other strings...
);
log.info(
`remove this instruction!!!
);
log.info(
`DEBUG other strings...
);
log.info(`remove this instruction!!!);
log.info(`DEBUG other strings...);
log.info(
`other strings DEBUG...
);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}