import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\blog\\.(?:info|warn|error)\\((?!\\s*`DEBUG\\b)[\\w\\W]*?\\);";
final String string = "log.info(\n"
+ " `DEBUG other strings...\n"
+ ");\n"
+ "log.info(\n"
+ " `remove this instruction!!!\n"
+ ");\n"
+ "log.info(\n"
+ " `DEBUG other strings...\n"
+ ");\n"
+ "log.info(`remove this instruction!!!);\n"
+ "log.info(`DEBUG other strings...);\n\n"
+ "log.info(\n"
+ " `other strings DEBUG...\n"
+ ");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}