const regex = /\blog\.(?:info|warn|error)\((?!\s*`DEBUG\b)[\w\W]*?\);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\blog\\.(?:info|warn|error)\\((?!\\s*`DEBUG\\b)[\\w\\W]*?\\);', 'gm')
const str = `log.info(
\`DEBUG other strings...
);
log.info(
\`remove this instruction!!!
);
log.info(
\`DEBUG other strings...
);
log.info(\`remove this instruction!!!);
log.info(\`DEBUG other strings...);
log.info(
\`other strings DEBUG...
);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}