$re = '/\blog\.(?:info|warn|error)\((?!\s*`DEBUG\b)[\w\W]*?\);/m';
$str = 'log.info(
`DEBUG other strings...
);
log.info(
`remove this instruction!!!
);
log.info(
`DEBUG other strings...
);
log.info(`remove this instruction!!!);
log.info(`DEBUG other strings...);
log.info(
`other strings DEBUG...
);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);